Loading Blackrock Microsystems Event and Continuous Data Files into Plexon Offline Sorter

Neural event (.nev) and continuously data (.nsx) files recorded from a Cerebus or Cereplex Direct can easily be post-processed using the Plexon Offline Sorter (OFS). To load the Blackrock Microsystems neural data files into the OFS, you must first download the Neuroshare Loader. Extract the dll files and place them in the Central Windows Suite File within Programs Files (x86). To add the dll path, open OFS and go to

Tools->Data Import Options->Cyberkinetics

Select Neuroshare Loader and browse to the nsNEVLibrary.dll or nsNEVLibrary64.dll in the Windows folder of the unzipped Neuroshare file.

The desired NEV and corresponding NSx files should have identical file names and be placed in that same folder. To import that data, go to

File->Import-> Cyberkinetics File

Only the .nev file will be visible, but any identically named .nsx files will be automatically uploaded with the .nev file. Note, large files will take time to load.

The imported data will be visible on the upper right hand panel in the “Channels” window. Neural Events (spike) channels will be displayed at the top, with continuously recorded channels below. You can differentiate the acquisition rate of each continuously recorded channel by the total number of samples.

The spikes are imported with an incorrect voltage full scale voltage at the probe; by default it is set to 5000 mV, but it should be 8.197 mV. To scale spike waveforms correctly, select the desired spike channel in the “Channels” window then go to

Tools->Adjust Gain

In the “Adjust Gain” panel, select the “Optimize” button. This will change the voltage at the probe to be 0.0025 mV/bit. To propagate this change to all of the spike channels, press the “Set Gains on a Range of Channels” and make sure that all of the spike channels are within the displayed range.

To detect spikes from continuously recorded data click on the desired channel in the “Channels” window. The continuous data time series will appear in the “Timeline” panel. Adjust the gains for the continuously recorded data the same way gain was adjusted for the spike channels (the channels will be numbered by the row in the “Channels” window). The data can then be filtered using the Low-cut filter on the left part of the panel. To detect waveforms, set the threshold level using the slider or the parameter boxes on the left then press “Detect”. The spike waveforms will now be displayed in the “Waveform” panel.